0


0

Redmineの補間引数エラーがありません

少しのグーグルで、このエラーはRailsバージョン<2.3.6で発生すると信じられました。 だから私は自分の環境ファイルを

RAILS_GEM_VERSION = '2.3.8' unless defined? RAILS_GEM_VERSION

今、私は2つの質問があります。

  1. Redmineエラーが引き続き発生します。

  2. スクリプト/サーバーを実行すると、Rails 2.3.5アプリケーションが取得されます http://0.0.0.0:3000以降

Rails 2.3.8をロードするように明確に指示しましたが! 何か案は ? ありがとうございます。

1 回答


1


最初、Redmineは現在Rails 2.3.5のみをサポートしています*のみ*。 他のバージョン(2.3.8を含む)で問題が発生します。 したがって、それらを使用しないでください。

あなたが言及したエラーは、i18n gem> = 0.4が原因です。 最近の1.0リリースでは、この問題を修正する必要があります。 回避策は、http://www.redmine.org/projects/redmine/repository/revisions/4183 [r4183]のtrunkにコミットされ、http://www.redmine.org/projects/redmine/で1.0安定版に取り込まれました。リポジトリ/リビジョン/ 4202 [r4202]。 そのため、最新の1.0.xリリース(現在のバージョンは1.0.2)に更新すると、問題が修正されます。 詳細については、Redmineの問題http://www.redmine.org/issues/6428[#6428]を参照してください。

もう1つの可能性は、Rails 2.3.5やRedmineでは必要ないため、i18n gemを完全に削除することです。